aboutsummaryrefslogtreecommitdiff
path: root/modules/xsession.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2017-01-28 18:29:27 +0100
committerRobert Helgesson <robert@rycee.net>2017-01-28 18:29:27 +0100
commit11ef3873cd47ce0781a41af2f23c5f6c1e9880d9 (patch)
tree2e17e32544e6f849c60ddb5e734648dfb31d09ee /modules/xsession.nix
parent10031e16bfd2fe6eb622fbf6aa683006b55542aa (diff)
xsession: always source `~/.profile`
It seems to be pretty standard to do this so always do it, not just when Bash is the session variable setter.
Diffstat (limited to 'modules/xsession.nix')
-rw-r--r--modules/xsession.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/modules/xsession.nix b/modules/xsession.nix
index f498d51786a..f18d7e8b7b5 100644
--- a/modules/xsession.nix
+++ b/modules/xsession.nix
@@ -72,12 +72,9 @@ in
home.file.".xsession" = {
mode = "555";
text = ''
- ${
- # If we want bash to set the session variables then we need
- # to pull in .profile since that's where they are.
- optionalString (config.home.sessionVariableSetter == "bash")
- ". \"$HOME/.profile\""
- }
+ if [[ -e "$HOME/.profile" ]]; then
+ . "$HOME/.profile"
+ fi
systemctl --user import-environment DBUS_SESSION_BUS_ADDRESS
systemctl --user import-environment DISPLAY