aboutsummaryrefslogtreecommitdiff
path: root/modules/services/unison.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /modules/services/unison.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to 'modules/services/unison.nix')
-rw-r--r--modules/services/unison.nix21
1 files changed, 7 insertions, 14 deletions
diff --git a/modules/services/unison.nix b/modules/services/unison.nix
index fc998e39a00..93c59e8fd62 100644
--- a/modules/services/unison.nix
+++ b/modules/services/unison.nix
@@ -7,10 +7,8 @@ let
cfg = config.services.unison;
pairOf = t:
- let
- list = types.addCheck (types.listOf t) (l: length l == 2);
- in
- list // { description = list.description + " of length 2"; };
+ let list = types.addCheck (types.listOf t) (l: length l == 2);
+ in list // { description = list.description + " of length 2"; };
pairOptions = {
options = {
@@ -64,17 +62,14 @@ let
serialiseArg = key: val: "-${key}=${escapeShellArg val}";
- serialiseArgs = args:
- concatStringsSep " " (mapAttrsToList serialiseArg args);
+ serialiseArgs = args: concatStringsSep " " (mapAttrsToList serialiseArg args);
makeDefs = gen:
mapAttrs'
- (name: pairCfg: nameValuePair "unison-pair-${name}" (gen name pairCfg))
- cfg.pairs;
+ (name: pairCfg: nameValuePair "unison-pair-${name}" (gen name pairCfg))
+ cfg.pairs;
-in
-
-{
+in {
meta.maintainers = with maintainers; [ pacien ];
options.services.unison = {
@@ -120,9 +115,7 @@ in
'';
};
- Install = {
- WantedBy = [ "default.target" ];
- };
+ Install = { WantedBy = [ "default.target" ]; };
});
};
}