aboutsummaryrefslogtreecommitdiff
path: root/modules/services/syncthing.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /modules/services/syncthing.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to 'modules/services/syncthing.nix')
-rw-r--r--modules/services/syncthing.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/modules/services/syncthing.nix b/modules/services/syncthing.nix
index 7fc556c5234..2ef10540164 100644
--- a/modules/services/syncthing.nix
+++ b/modules/services/syncthing.nix
@@ -22,21 +22,21 @@ with lib;
systemd.user.services = {
syncthing = {
Unit = {
- Description = "Syncthing - Open Source Continuous File Synchronization";
+ Description =
+ "Syncthing - Open Source Continuous File Synchronization";
Documentation = "man:syncthing(1)";
After = [ "network.target" ];
};
Service = {
- ExecStart = "${pkgs.syncthing}/bin/syncthing -no-browser -no-restart -logflags=0";
+ ExecStart =
+ "${pkgs.syncthing}/bin/syncthing -no-browser -no-restart -logflags=0";
Restart = "on-failure";
SuccessExitStatus = [ 3 4 ];
RestartForceExitStatus = [ 3 4 ];
};
- Install = {
- WantedBy = [ "default.target" ];
- };
+ Install = { WantedBy = [ "default.target" ]; };
};
};
})
@@ -46,10 +46,12 @@ with lib;
qsyncthingtray = {
Unit = {
Description = "QSyncthingTray";
- After = [ "graphical-session-pre.target"
- "polybar.service"
- "taffybar.service"
- "stalonetray.service" ];
+ After = [
+ "graphical-session-pre.target"
+ "polybar.service"
+ "taffybar.service"
+ "stalonetray.service"
+ ];
PartOf = [ "graphical-session.target" ];
};
@@ -58,9 +60,7 @@ with lib;
ExecStart = "${pkgs.qsyncthingtray}/bin/QSyncthingTray";
};
- Install = {
- WantedBy = [ "graphical-session.target" ];
- };
+ Install = { WantedBy = [ "graphical-session.target" ]; };
};
};
})