aboutsummaryrefslogtreecommitdiff
path: root/modules/services/pasystray.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /modules/services/pasystray.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to 'modules/services/pasystray.nix')
-rw-r--r--modules/services/pasystray.nix32
1 files changed, 13 insertions, 19 deletions
diff --git a/modules/services/pasystray.nix b/modules/services/pasystray.nix
index 8f92f34c091..7c6651d9499 100644
--- a/modules/services/pasystray.nix
+++ b/modules/services/pasystray.nix
@@ -6,31 +6,25 @@ with lib;
meta.maintainers = [ maintainers.pltanton ];
options = {
- services.pasystray = {
- enable = mkEnableOption "PulseAudio system tray";
- };
+ services.pasystray = { enable = mkEnableOption "PulseAudio system tray"; };
};
config = mkIf config.services.pasystray.enable {
systemd.user.services.pasystray = {
- Unit = {
- Description = "PulseAudio system tray";
- After = [ "graphical-session-pre.target" ];
- PartOf = [ "graphical-session.target" ];
- };
+ Unit = {
+ Description = "PulseAudio system tray";
+ After = [ "graphical-session-pre.target" ];
+ PartOf = [ "graphical-session.target" ];
+ };
- Install = {
- WantedBy = [ "graphical-session.target" ];
- };
+ Install = { WantedBy = [ "graphical-session.target" ]; };
- Service = {
- Environment =
- let
- toolPaths = makeBinPath [ pkgs.paprefs pkgs.pavucontrol ];
- in
- [ "PATH=${toolPaths}" ];
- ExecStart = "${pkgs.pasystray}/bin/pasystray";
- };
+ Service = {
+ Environment =
+ let toolPaths = makeBinPath [ pkgs.paprefs pkgs.pavucontrol ];
+ in [ "PATH=${toolPaths}" ];
+ ExecStart = "${pkgs.pasystray}/bin/pasystray";
+ };
};
};
}