aboutsummaryrefslogtreecommitdiff
path: root/modules/services/mpd.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2019-09-16 21:43:53 +0200
committerRobert Helgesson <robert@rycee.net>2019-09-16 21:43:53 +0200
commitb0544c8cded820fc1439c26b4fc7485846430516 (patch)
tree912929af6a0cdeb753d19b6357a1afecfa45941e /modules/services/mpd.nix
parente347e932afb1fe3b3c545c4ac7a4d90cd2072fde (diff)
mpd: allow path literal values in options
This allows specifying, for example, the music directory using path literals without causing the directory to be copied to the Nix store. Suggested-by: Silvan Mosberger <infinisil@icloud.com>
Diffstat (limited to 'modules/services/mpd.nix')
-rw-r--r--modules/services/mpd.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/modules/services/mpd.nix b/modules/services/mpd.nix
index 5dc80a4a345..2aa1cd3a9fe 100644
--- a/modules/services/mpd.nix
+++ b/modules/services/mpd.nix
@@ -45,6 +45,7 @@ in {
type = types.path;
default = "${config.home.homeDirectory}/music";
defaultText = "$HOME/music";
+ apply = toString; # Prevent copies to Nix store.
description = ''
The directory where mpd reads music from.
'';
@@ -54,6 +55,7 @@ in {
type = types.path;
default = "${cfg.dataDir}/playlists";
defaultText = ''''${dataDir}/playlists'';
+ apply = toString; # Prevent copies to Nix store.
description = ''
The directory where mpd stores playlists.
'';
@@ -78,6 +80,7 @@ in {
type = types.path;
default = "${config.xdg.dataHome}/${name}";
defaultText = "$XDG_DATA_HOME/mpd";
+ apply = toString; # Prevent copies to Nix store.
description = ''
The directory where MPD stores its state, tag cache,
playlists etc.