aboutsummaryrefslogtreecommitdiff
path: root/modules/services/mbsync.nix
diff options
context:
space:
mode:
authorDaniƫl de Kok <me@danieldk.eu>2018-10-13 19:19:09 +0200
committerDaniƫl de Kok <me@danieldk.eu>2018-10-13 19:28:40 +0200
commit05a98b6be06d68c4a6086a0adb0a9b058833b41a (patch)
tree0490df347d0620b9f311a5a3a5e9996dac485507 /modules/services/mbsync.nix
parent52b93637453cb120feb039ecea8f42c949e1abf6 (diff)
mbsync: change service unit type to 'oneshot'
The ExecStartPost command is currently started when the mbsync is invoked succesfully. However, we typically want to run something like 'mu index' or 'notmuch new' after mbsync completes. This changes the unit type to oneshot, so that the ExecStartPost command is run after mbsync finishes succesfully.
Diffstat (limited to 'modules/services/mbsync.nix')
-rw-r--r--modules/services/mbsync.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/modules/services/mbsync.nix b/modules/services/mbsync.nix
index a14e252371c..5c994cc6bc3 100644
--- a/modules/services/mbsync.nix
+++ b/modules/services/mbsync.nix
@@ -87,7 +87,7 @@ in
};
Service = {
- Type = "simple";
+ Type = "oneshot";
ExecStart = "${cfg.package}/bin/mbsync ${concatStringsSep " " mbsyncOptions}";
} // (optionalAttrs (cfg.postExec != null) { ExecStartPost = cfg.postExec; })
// (optionalAttrs (cfg.preExec != null) { ExecStartPre = cfg.preExec; });