aboutsummaryrefslogtreecommitdiff
path: root/modules/services/gnome-keyring.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /modules/services/gnome-keyring.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to 'modules/services/gnome-keyring.nix')
-rw-r--r--modules/services/gnome-keyring.nix27
1 files changed, 9 insertions, 18 deletions
diff --git a/modules/services/gnome-keyring.nix b/modules/services/gnome-keyring.nix
index 4ca6c7cacf2..6d8317dcffc 100644
--- a/modules/services/gnome-keyring.nix
+++ b/modules/services/gnome-keyring.nix
@@ -6,9 +6,7 @@ let
cfg = config.services.gnome-keyring;
-in
-
-{
+in {
meta.maintainers = [ maintainers.rycee ];
options = {
@@ -16,8 +14,8 @@ in
enable = mkEnableOption "GNOME Keyring";
components = mkOption {
- type = types.listOf (types.enum ["pkcs11" "secrets" "ssh"]);
- default = [];
+ type = types.listOf (types.enum [ "pkcs11" "secrets" "ssh" ]);
+ default = [ ];
description = ''
The GNOME keyring components to start. If empty then the
default set of components will be started.
@@ -34,22 +32,15 @@ in
};
Service = {
- ExecStart =
- let
- args = concatStringsSep " " (
- [ "--start" "--foreground" ]
- ++ optional (cfg.components != []) (
- "--components=" + concatStringsSep "," cfg.components
- )
- );
- in
- "${pkgs.gnome3.gnome_keyring}/bin/gnome-keyring-daemon ${args}";
+ ExecStart = let
+ args = concatStringsSep " " ([ "--start" "--foreground" ]
+ ++ optional (cfg.components != [ ])
+ ("--components=" + concatStringsSep "," cfg.components));
+ in "${pkgs.gnome3.gnome_keyring}/bin/gnome-keyring-daemon ${args}";
Restart = "on-abort";
};
- Install = {
- WantedBy = [ "graphical-session-pre.target" ];
- };
+ Install = { WantedBy = [ "graphical-session-pre.target" ]; };
};
};
}