aboutsummaryrefslogtreecommitdiff
path: root/modules/services/fluidsynth.nix
diff options
context:
space:
mode:
authorVincent Breitmoser <look@my.amazin.horse>2020-06-13 13:34:16 +0200
committerRobert Helgesson <robert@rycee.net>2020-06-14 15:30:51 +0200
commitb0e8a1569ed289ae1c644277b720882baba9304e (patch)
tree80bd5772d8bdd2228fd97a9a7e280c12445b97a3 /modules/services/fluidsynth.nix
parent1b210e7143547ce0f41e8082b8d27e9c7d220351 (diff)
fluidsynth: add module
Fluidsynth is a real-time MIDI synthesizer based on the SoundFont 2 format. PR #1326
Diffstat (limited to 'modules/services/fluidsynth.nix')
-rw-r--r--modules/services/fluidsynth.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/modules/services/fluidsynth.nix b/modules/services/fluidsynth.nix
new file mode 100644
index 00000000000..35096115257
--- /dev/null
+++ b/modules/services/fluidsynth.nix
@@ -0,0 +1,57 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+ cfg = config.services.fluidsynth;
+
+in {
+ meta.maintainers = [ maintainers.valodim ];
+
+ options = {
+ services.fluidsynth = {
+ enable = mkEnableOption "fluidsynth, the music player daemon";
+
+ soundFont = mkOption {
+ type = types.path;
+ default = "${pkgs.soundfont-fluid}/share/soundfonts/FluidR3_GM2-2.sf2";
+ description = ''
+ The soundfont file to use, in SoundFont 2 format.
+ '';
+ };
+
+ extraOptions = mkOption {
+ type = types.listOf types.str;
+ default = [ ];
+ example = [ "--sample-rate 96000" ];
+ description = ''
+ Extra arguments, added verbatim to the fluidsynth command. See
+ <citerefentry>
+ <refentrytitle>fluidsynth.conf</refentrytitle>
+ <manvolnum>1</manvolnum>
+ </citerefentry>.
+ '';
+ };
+ };
+ };
+
+ config = mkIf cfg.enable {
+ systemd.user.services.fluidsynth = {
+ Unit = {
+ Description = "FluidSynth Daemon";
+ Documentation = "man:fluidsynth(1)";
+ BindsTo = [ "pulseaudio.service" ];
+ After = [ "pulseaudio.service" ];
+ };
+
+ Install = { WantedBy = [ "default.target" ]; };
+
+ Service = {
+ ExecStart = "${pkgs.fluidsynth}/bin/fluidsynth -a pulseaudio -si ${
+ lib.concatStringsSep " " cfg.extraOptions
+ } ${cfg.soundFont}";
+ };
+ };
+ };
+}