aboutsummaryrefslogtreecommitdiff
path: root/modules/services/dunst.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2017-01-07 19:16:26 +0100
committerRobert Helgesson <robert@rycee.net>2017-01-14 13:15:24 +0100
commitd7d02c3ce8f723b3cff03ea7502011883eef8fde (patch)
treef48d291967d59a91dd6590941745fb876c3a29bf /modules/services/dunst.nix
parente4c63eb66aaa10e447f010b3d0f28e3a278ad30d (diff)
Initial import
Diffstat (limited to 'modules/services/dunst.nix')
-rw-r--r--modules/services/dunst.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/modules/services/dunst.nix b/modules/services/dunst.nix
new file mode 100644
index 00000000000..8042cf93d41
--- /dev/null
+++ b/modules/services/dunst.nix
@@ -0,0 +1,35 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ options = {
+ services.dunst = {
+ enable = mkEnableOption "the dunst notification daemon";
+
+ settings = mkOption {
+ type = types.attrs;
+ default = {};
+ description = "Configuration written to ~/.config/dunstrc";
+ };
+ };
+ };
+
+ config = mkIf config.services.dunst.enable {
+ systemd.user.services.dunst = {
+ Unit = {
+ Description = "Dunst notification daemon";
+ };
+
+ Install = {
+ WantedBy = [ "xorg.target" ];
+ };
+
+ Service = {
+ # Type = "dbus";
+ # BusName = "org.freedesktop.Notifications";
+ ExecStart = "${pkgs.dunst}/bin/dunst";
+ };
+ };
+ };
+}