aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/notmuch.nix
diff options
context:
space:
mode:
authorNick Hu <me@nickhu.co.uk>2019-04-10 14:24:35 +0100
committerMatthieu Coudron <coudron@iij.ad.jp>2019-04-11 23:28:36 +0900
commitd49b514aa610f7412e4d030b159daf978ee2281e (patch)
treec50ba30e75d001d7d2da311aa407701e22dd43c3 /modules/programs/notmuch.nix
parentb6e1d826850fdcd79e067677ec0d5ec20fdf12b7 (diff)
make notmuch search.exclude_tags configurable
Diffstat (limited to 'modules/programs/notmuch.nix')
-rw-r--r--modules/programs/notmuch.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/modules/programs/notmuch.nix b/modules/programs/notmuch.nix
index a5ded5680e4..1886aee3942 100644
--- a/modules/programs/notmuch.nix
+++ b/modules/programs/notmuch.nix
@@ -46,7 +46,7 @@ let
};
search = {
- exclude_tags = [ "deleted" "spam" ];
+ exclude_tags = cfg.search.excludeTags;
};
}
cfg.extraConfig;
@@ -138,6 +138,19 @@ in
'';
};
};
+
+ search = {
+ excludeTags = mkOption {
+ type = types.listOf types.str;
+ default = [ "deleted" "spam" ];
+ example = [ "trash" "spam" ];
+ description = ''
+ A list of tags that will be excluded from search results by
+ default. Using an excluded tag in a query will override that
+ exclusion.
+ '';
+ };
+ };
};
};