aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/noti.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-02-02 00:39:17 +0100
committerRobert Helgesson <robert@rycee.net>2020-02-02 01:07:28 +0100
commit45abf3d38a2b51c00c347cab6950f3734e023bba (patch)
tree414fde5d14d1d075fa65e59175660fd1fb680c43 /modules/programs/noti.nix
parent9799d3de2d270a9c40fcf81d600bfd71088e144d (diff)
Apply `nixfmt` on many files
Diffstat (limited to 'modules/programs/noti.nix')
-rw-r--r--modules/programs/noti.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/modules/programs/noti.nix b/modules/programs/noti.nix
index 476c2eb1978..348555eef51 100644
--- a/modules/programs/noti.nix
+++ b/modules/programs/noti.nix
@@ -1,4 +1,4 @@
-{ config, lib, pkgs, ...}:
+{ config, lib, pkgs, ... }:
with lib;
@@ -6,9 +6,7 @@ let
cfg = config.programs.noti;
-in
-
-{
+in {
meta.maintainers = [ maintainers.marsam ];
options.programs.noti = {
@@ -16,7 +14,7 @@ in
settings = mkOption {
type = types.attrsOf (types.attrsOf types.str);
- default = {};
+ default = { };
description = ''
Configuration written to
<filename>~/.config/noti/noti.yaml</filename>.
@@ -45,9 +43,8 @@ in
config = mkIf cfg.enable {
home.packages = [ pkgs.noti ];
- xdg.configFile."noti/noti.yaml" = mkIf (cfg.settings != {}) {
- text = generators.toYAML {} cfg.settings;
- };
+ xdg.configFile."noti/noti.yaml" =
+ mkIf (cfg.settings != { }) { text = generators.toYAML { } cfg.settings; };
};
}