aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/neovim.nix
diff options
context:
space:
mode:
authorMatthieu Coudron <mattator@gmail.com>2019-02-04 14:57:26 +0900
committerRobert Helgesson <robert@rycee.net>2019-02-04 21:52:01 +0100
commitc18984c452013ff0edb3d67ab0a1a245333dd4ce (patch)
tree3d86172229f525e598b7f7c1e7e4e46ac284b5b8 /modules/programs/neovim.nix
parent445c0b1482c38172a9f8294ee16a7ca7462388e5 (diff)
neovim: allow to override package
If you want to run a development version for instance, it is easier to set neovim.package rather than work around the wrapping mechanism etc.
Diffstat (limited to 'modules/programs/neovim.nix')
-rw-r--r--modules/programs/neovim.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/modules/programs/neovim.nix b/modules/programs/neovim.nix
index 304a273b6a0..7f2a9aaa115 100644
--- a/modules/programs/neovim.nix
+++ b/modules/programs/neovim.nix
@@ -104,6 +104,13 @@ in
'';
};
+ package = mkOption {
+ type = types.package;
+ default = pkgs.neovim-unwrapped;
+ defaultText = "pkgs.neovim-unwrapped";
+ description = "The package to use for the neovim binary.";
+ };
+
configure = mkOption {
type = types.attrs;
default = {};
@@ -130,7 +137,7 @@ in
config = mkIf cfg.enable {
home.packages = [
- (pkgs.neovim.override {
+ (pkgs.wrapNeovim cfg.package {
inherit (cfg)
extraPython3Packages withPython3
extraPythonPackages withPython