aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/neovim.nix
diff options
context:
space:
mode:
authorRoman Volosatovs <rvolosatovs@riseup.net>2018-08-18 04:50:49 +0200
committerNikita Uvarov <uv.nikita@gmail.com>2018-09-04 07:32:01 +0200
commit9fe6fa7f44d8672f1824620192fe585edee14fcc (patch)
tree8f84bacd56021c8ea0b145f6810a21a348a77d89 /modules/programs/neovim.nix
parent7699ed3fc8a5ff4ba3e2b936c85e7008ed72d508 (diff)
neovim: add vi{,m}Alias options
Diffstat (limited to 'modules/programs/neovim.nix')
-rw-r--r--modules/programs/neovim.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/modules/programs/neovim.nix b/modules/programs/neovim.nix
index d0f1002620b..2e9cbca6725 100644
--- a/modules/programs/neovim.nix
+++ b/modules/programs/neovim.nix
@@ -13,6 +13,22 @@ in
programs.neovim = {
enable = mkEnableOption "Neovim";
+ viAlias = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Symlink `vi` to `nvim` binary.
+ '';
+ };
+
+ vimAlias = mkOption {
+ type = types.bool;
+ default = false;
+ description = ''
+ Symlink `vim` to `nvim` binary.
+ '';
+ };
+
withPython = mkOption {
type = types.bool;
default = true;
@@ -89,7 +105,7 @@ in
inherit (cfg)
extraPython3Packages withPython3
extraPythonPackages withPython
- withRuby configure;
+ withRuby viAlias vimAlias configure;
})
];
};