aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/man.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2017-10-15 16:01:41 +0200
committerRobert Helgesson <robert@rycee.net>2017-10-15 16:01:41 +0200
commit3632478b8d91a56711b0434707e0982ec8688d88 (patch)
tree53410ef869dfa87e062783052fa5bf27d63840df /modules/programs/man.nix
parentc07fa70d58738eb28cfb84c089cccc8de96783e8 (diff)
man: add module
Diffstat (limited to 'modules/programs/man.nix')
-rw-r--r--modules/programs/man.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/programs/man.nix b/modules/programs/man.nix
new file mode 100644
index 00000000000..702b8932ded
--- /dev/null
+++ b/modules/programs/man.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ options = {
+ programs.man.enable = mkOption {
+ type = types.bool;
+ default = true;
+ description = ''
+ Whether to enable manual pages and the <command>man</command>
+ command. This also includes "man" outputs of all
+ <literal>home.packages</literal>.
+ '';
+ };
+ };
+
+ config = mkIf config.programs.man.enable {
+ home.packages = [ pkgs.man-db ];
+ home.extraOutputsToInstall = [ "man" ];
+ };
+}