aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/gnome-terminal.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2017-02-05 12:01:49 +0100
committerRobert Helgesson <robert@rycee.net>2017-02-05 12:01:49 +0100
commit119c7b25382eae7321db13a4aded56e50f86e363 (patch)
tree46d060fd0d55b4aa4883bf7b6045d8adb4441bcd /modules/programs/gnome-terminal.nix
parent34d472886d0d91af3440f97ece54f17cc5da14e1 (diff)
gnome-terminal: load configuration at right time
If the dconf service hasn't been installed then the configuration activation will fail. Thus, make sure the activation script is run after packages have been installed.
Diffstat (limited to 'modules/programs/gnome-terminal.nix')
-rw-r--r--modules/programs/gnome-terminal.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/programs/gnome-terminal.nix b/modules/programs/gnome-terminal.nix
index ca5513cd73a..bbeab158ef5 100644
--- a/modules/programs/gnome-terminal.nix
+++ b/modules/programs/gnome-terminal.nix
@@ -182,7 +182,8 @@ in
sf = pkgs.writeText "gnome-terminal.ini" (toINI (buildIniSet cfg));
dconfPath = "/org/gnome/terminal/legacy/";
in
- ''
+ # The dconf service needs to be installed and prepared.
+ stringAfter [ "installPackages" ] ''
if [[ $DRY_RUN ]]; then
echo ${pkgs.gnome3.dconf}/bin/dconf load ${dconfPath} "<" ${sf}
else