aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/fish.nix
diff options
context:
space:
mode:
authorRyan Orendorff <ryan@orendorff.io>2019-09-22 23:54:08 -0700
committerRobert Helgesson <robert@rycee.net>2020-02-19 23:42:53 +0100
commit665766f8bb1e36ea873ed7dd3ac06cef6045b78f (patch)
tree20ce788d48c3d818c25cd9135bd22aaf0bc9bfc3 /modules/programs/fish.nix
parent2eb1cb077d00f1668ad997e892b719856c7c9b93 (diff)
fish: add examples for shellAliases, shellAbbrs
Diffstat (limited to 'modules/programs/fish.nix')
-rw-r--r--modules/programs/fish.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/modules/programs/fish.nix b/modules/programs/fish.nix
index bdd0c870e39..b5bf77f9c95 100644
--- a/modules/programs/fish.nix
+++ b/modules/programs/fish.nix
@@ -62,6 +62,7 @@ in
shellAliases = mkOption {
type = types.attrs;
default = {};
+ example = { ".." = "cd .."; ll = "ls -l"; };
description = ''
Set of aliases for fish shell. See
<option>environment.shellAliases</option> for an option
@@ -72,6 +73,7 @@ in
shellAbbrs = mkOption {
type = types.attrs;
default = {};
+ example = { l = "less"; gco = "git checkout"; };
description = ''
Set of abbreviations for fish shell.
'';