aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/fish.nix
diff options
context:
space:
mode:
authorRyan Orendorff <ryan@orendorff.io>2019-09-23 22:14:32 -0700
committerRobert Helgesson <robert@rycee.net>2020-02-20 00:03:19 +0100
commit0740c257b11de90ba04860a04c80ddfd2d81f111 (patch)
treee97113057e4c6e1dea819a9503588a7323994d54 /modules/programs/fish.nix
parent490f5fc5851bbed95a491b38e57890840ca64296 (diff)
fish: remove fileType function
Replaced by types that are more common. This additionally reflects in the manpages, which should have types the reader is familiar with.
Diffstat (limited to 'modules/programs/fish.nix')
-rw-r--r--modules/programs/fish.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/programs/fish.nix b/modules/programs/fish.nix
index 3cfbfa4b376..52ea9189acb 100644
--- a/modules/programs/fish.nix
+++ b/modules/programs/fish.nix
@@ -14,35 +14,6 @@ let
mapAttrsToList (k: v: "alias ${k}='${v}'") cfg.shellAliases
);
- fileType = textGen: types.submodule (
- { name, config, ... }: {
- options = {
- body = mkOption {
- default = null;
- type = types.nullOr types.lines;
- description = "Body of the file.";
- };
-
- source = mkOption {
- type = types.path;
- description = ''
- Path of the source file. The file name must not start
- with a period.
- '';
- };
- };
-
- config = {
- source = mkIf (config.body != null) (
- mkDefault (pkgs.writeTextFile {
- inherit name;
- text = textGen name config.body;
- executable = true;
- })
- );
- };
- }
- );
in
{