aboutsummaryrefslogtreecommitdiff
path: root/modules/programs/astroid-accounts.nix
diff options
context:
space:
mode:
authorMatthieu Coudron <mattator@gmail.com>2018-09-30 18:06:02 +0900
committerMatthieu Coudron <coudron@iij.ad.jp>2018-11-12 23:16:03 +0900
commit736e340bde8831e1ffb3e423056a801d0546a83c (patch)
tree8dbcab2e3e4110c86fc87550f3f798f96ced5bd7 /modules/programs/astroid-accounts.nix
parent05c93ff3ae13f1a2d90a279a890534cda7dc8ad6 (diff)
astroid: init
Astroid is a notmuch/gtk based MUA: https://github.com/astroidmail/astroid
Diffstat (limited to 'modules/programs/astroid-accounts.nix')
-rw-r--r--modules/programs/astroid-accounts.nix41
1 files changed, 41 insertions, 0 deletions
diff --git a/modules/programs/astroid-accounts.nix b/modules/programs/astroid-accounts.nix
new file mode 100644
index 00000000000..0bcf17e9081
--- /dev/null
+++ b/modules/programs/astroid-accounts.nix
@@ -0,0 +1,41 @@
+{ config, lib, ... }:
+
+with lib;
+{
+
+ options.astroid = {
+ enable = mkEnableOption "Astroid";
+
+ sendMailCommand = mkOption {
+ type = types.nullOr types.str;
+ description = ''
+ Command to send a mail. If msmtp is enabled for the account,
+ then this is set to
+ <command>msmtpq --read-envelope-from --read-recipients</command>.
+ '';
+ };
+
+ extraConfig = mkOption {
+ type = types.attrs;
+ default = {};
+ example = ''
+ {
+ select_query = "";
+ }
+ '';
+ description = ''
+ Extra settings to add to this astroid account configuration.
+ '';
+ };
+
+ };
+
+
+ config = mkIf config.notmuch.enable {
+ astroid.sendMailCommand = mkOptionDefault (
+ if config.msmtp.enable
+ then "msmtpq --read-envelope-from --read-recipients"
+ else null
+ );
+ };
+}