aboutsummaryrefslogtreecommitdiff
path: root/modules/misc/submodule-support.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2019-02-09 15:08:16 +0100
committerRobert Helgesson <robert@rycee.net>2019-02-10 00:44:55 +0100
commit2f372ab4d670c2b685a8f603d078cf3ddfa7e6cd (patch)
tree1c8f9e097faf9a3f1549574c55e8911cf7caf93d /modules/misc/submodule-support.nix
parent524ce43e233be08d77b4ad813e4e79a7fef65cee (diff)
Clean up support code for Home Manager as a submodule
This removes the `nixosSubmodule` option in favor of a new option `submoduleSupport.enable`. This name better indicates that the submodule mode applies to both NixOS and nix-darwin.
Diffstat (limited to 'modules/misc/submodule-support.nix')
-rw-r--r--modules/misc/submodule-support.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/misc/submodule-support.nix b/modules/misc/submodule-support.nix
new file mode 100644
index 00000000000..cffdcb9e95c
--- /dev/null
+++ b/modules/misc/submodule-support.nix
@@ -0,0 +1,19 @@
+{ lib, ... }:
+
+with lib;
+
+{
+ meta.maintainers = [ maintainers.rycee ];
+
+ options.submoduleSupport = {
+ enable = mkOption {
+ type = types.bool;
+ default = false;
+ internal = true;
+ description = ''
+ Whether the Home Manager module system is used as a submodule
+ in, for example, NixOS or nix-darwin.
+ '';
+ };
+ };
+}