aboutsummaryrefslogtreecommitdiff
path: root/modules/manual.nix
diff options
context:
space:
mode:
authorAlex Ameen <alex.ameen.tx@gmail.com>2019-04-13 02:39:14 -0500
committerRobert Helgesson <robert@rycee.net>2019-04-15 22:43:46 +0200
commitff602cb906e3dd5d5f89c7c1d0fae65bc67119a0 (patch)
treef93ba17b9ab55f692932652011129da7fccb12c7 /modules/manual.nix
parent1806e5511efb06cd64c4bdd4e0a98ab1b5ad1542 (diff)
manual: add option `manual.json.enable`
Make it possible to install a JSON file containing the available Home Manager options.
Diffstat (limited to 'modules/manual.nix')
-rw-r--r--modules/manual.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/modules/manual.nix b/modules/manual.nix
index d597d002dbf..0c2681b3acf 100644
--- a/modules/manual.nix
+++ b/modules/manual.nix
@@ -83,13 +83,26 @@ in
Thanks!
'';
};
+
+ manual.json.enable = mkOption {
+ type = types.bool;
+ default = false;
+ example = true;
+ description = ''
+ Whether to install a JSON formatted list of all Home Manager
+ options. This can be located at
+ <filename>&lt;profile directory&gt;/share/doc/home-manager/options.json</filename>,
+ and may be used for navigating definitions, auto-completing,
+ and other miscellaneous tasks.
+ '';
+ };
};
config = {
home.packages = mkMerge [
(mkIf cfg.html.enable [ helpScript homeManagerManual.manual ])
-
(mkIf cfg.manpages.enable [ homeManagerManual.manpages ])
+ (mkIf cfg.json.enable [ homeManagerManual.optionsJSON ])
];
};