aboutsummaryrefslogtreecommitdiff
path: root/modules/lib/default.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2020-01-16 23:41:14 +0100
committerRobert Helgesson <robert@rycee.net>2020-01-21 20:47:04 +0100
commit6e4b9af0803ac00e94398768c5d19d2e423b0be9 (patch)
tree65f117f6a8b562348eaf12469dadb084af2be417 /modules/lib/default.nix
parentc8323a0bf16acf2c9d89ce164568089017d19668 (diff)
Switch to extended Nixpkg's `lib`
This change makes use of the `extend` function inside `lib` to inject a new `hm` field containing the Home Manager library functions. This simplifies use of the Home Manager library in the modules and reduces the risk of accidental infinite recursion. PR #994
Diffstat (limited to 'modules/lib/default.nix')
-rw-r--r--modules/lib/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/lib/default.nix b/modules/lib/default.nix
index 754713cab5d..6b2bbacc249 100644
--- a/modules/lib/default.nix
+++ b/modules/lib/default.nix
@@ -1,6 +1,6 @@
{ lib }:
-{
+rec {
dag =
let
d = import ./dag.nix { inherit lib; };
@@ -17,6 +17,7 @@
};
strings = import ./strings.nix { inherit lib; };
+ types = import ./types.nix { inherit dag lib; };
shell = import ./shell.nix { inherit lib; };
zsh = import ./zsh.nix { inherit lib; };