aboutsummaryrefslogtreecommitdiff
path: root/modules/home-environment.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2017-03-25 21:48:17 +0100
committerRobert Helgesson <robert@rycee.net>2017-03-25 21:57:03 +0100
commitfea693ba16616890770d69b847744186f6a21930 (patch)
tree85cf8528ffbbdd684484eb9c57ecda3ef095e5e8 /modules/home-environment.nix
parent207c3498251b3a85f537dadbb7d7d04ddae885cf (diff)
Use stricter Bash settings in activation script
For example, with these settings Bash will complain if uninitialized variables are used. Some code has been improved to run cleanly with these settings.
Diffstat (limited to 'modules/home-environment.nix')
-rw-r--r--modules/home-environment.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/modules/home-environment.nix b/modules/home-environment.nix
index e492b8d5ece..cef70541a1a 100644
--- a/modules/home-environment.nix
+++ b/modules/home-environment.nix
@@ -328,7 +328,8 @@ in
sf = pkgs.writeText "activation-script" ''
#!${pkgs.stdenv.shell}
- set -e
+ set -eu
+ set -o pipefail
${builtins.readFile ./activation-init.sh}