aboutsummaryrefslogtreecommitdiff
path: root/modules/home-environment.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2018-09-14 21:08:51 +0200
committerRobert Helgesson <robert@rycee.net>2018-09-14 21:08:51 +0200
commitea7482017692d92e123b191abad2ff103280527a (patch)
tree677b1b4e723aafb2bbb747f20f27a6c4ddc6bcb6 /modules/home-environment.nix
parent50de1a6885dc7c306fa85c3c4538ee8ba54a65f7 (diff)
home-environment: add option `home.extraProfileCommands`
This _internal_ option indicates extra commands that should be run in the `postBuild` step of the profile environment build. Fixes #386
Diffstat (limited to 'modules/home-environment.nix')
-rw-r--r--modules/home-environment.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/home-environment.nix b/modules/home-environment.nix
index 229e3d22ff4..c98cb9ea966 100644
--- a/modules/home-environment.nix
+++ b/modules/home-environment.nix
@@ -243,6 +243,15 @@ in
Extra commands to run in the Home Manager generation builder.
'';
};
+
+ home.extraProfileCommands = mkOption {
+ type = types.lines;
+ default = "";
+ internal = true;
+ description = ''
+ Extra commands to run in the Home Manager profile builder.
+ '';
+ };
};
config = {
@@ -373,6 +382,8 @@ in
paths = cfg.packages;
inherit (cfg) extraOutputsToInstall;
+ postBuild = cfg.extraProfileCommands;
+
meta = {
description = "Environment of packages installed through home-manager";
};