aboutsummaryrefslogtreecommitdiff
path: root/modules/files.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2017-11-12 00:13:29 +0100
committerRobert Helgesson <robert@rycee.net>2017-11-12 00:13:29 +0100
commitd7537777c3c92ce3430257a947191081237457d8 (patch)
treec7cd9f01f0cfdfda37a5f26802fbc44adc3783c9 /modules/files.nix
parent145aefc9d159ecd0367f887ba0234739fcd8134a (diff)
files: improve keyword for inheriting executable bit
Diffstat (limited to 'modules/files.nix')
-rw-r--r--modules/files.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/files.nix b/modules/files.nix
index 406fdcf304b..f2495f5b418 100644
--- a/modules/files.nix
+++ b/modules/files.nix
@@ -225,7 +225,7 @@ in
install -m "$mode" "$source" "$target"
else
[[ -x $source ]] && isExecutable=1 || isExecutable=""
- if [[ $executable == symlink || $isExecutable == $executable ]]; then
+ if [[ $executable == inherit || $isExecutable == $executable ]]; then
ln -s "$source" "$target"
else
cp "$source" "$target"
@@ -242,7 +242,7 @@ in
insertFile "${v.source}" \
"${v.target}" \
"${if v.executable == null
- then "symlink"
+ then "inherit"
else builtins.toString v.executable}" \
"${builtins.toString v.mode}" \
"${builtins.toString v.recursive}"