aboutsummaryrefslogtreecommitdiff
path: root/modules/files.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2017-12-02 22:52:35 +0100
committerRobert Helgesson <robert@rycee.net>2017-12-12 18:05:04 +0100
commit8d360c5a573766bbd71b3fa0ac72b345fb7f07f5 (patch)
tree69aa39768f6b039c8afee07779dd56d048626d85 /modules/files.nix
parentf6900f06893e85d13edbb22bab6016de9de841a7 (diff)
systemd: remove filename hack
Diffstat (limited to 'modules/files.nix')
-rw-r--r--modules/files.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/modules/files.nix b/modules/files.nix
index 78554230ed4..b8efd886f11 100644
--- a/modules/files.nix
+++ b/modules/files.nix
@@ -237,13 +237,7 @@ in
# i.e., if the executable bit of the source is the same we
# expect for the target. Otherwise, we copy the file and
# set the executable bit to the expected value.
- #
- # Note, as a special case we always copy systemd units
- # because it derives the unit name from the ultimate link
- # target, which may be a store path with the hash
- # included.
- if [[ ($executable == inherit || $isExecutable == $executable) \
- && $relTarget != *"/systemd/user/"* ]]; then
+ if [[ $executable == inherit || $isExecutable == $executable ]]; then
ln -s "$source" "$target"
else
cp "$source" "$target"