aboutsummaryrefslogtreecommitdiff
path: root/modules/files.nix
diff options
context:
space:
mode:
authorpiegames <git@piegames.de>2020-05-14 16:02:31 +0200
committerRobert Helgesson <robert@rycee.net>2020-05-17 21:49:18 +0200
commit6c7a0313673687368a33197e58bc28f4290ec244 (patch)
tree1880fe5298270491e1b4c550bc94439c25afec1e /modules/files.nix
parent645149d77b8c604e10e94e2764ff2c782780242e (diff)
files: print source path for detected collision
PR #1236
Diffstat (limited to 'modules/files.nix')
-rw-r--r--modules/files.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/files.nix b/modules/files.nix
index c2992479629..199fd921ddb 100644
--- a/modules/files.nix
+++ b/modules/files.nix
@@ -90,10 +90,10 @@ in
errorEcho "Existing file '$backup' would be clobbered by backing up '$targetPath'"
collision=1
else
- warnEcho "Existing file '$targetPath' is in the way, will be moved to '$backup'"
+ warnEcho "Existing file '$targetPath' is in the way of '$sourcePath', will be moved to '$backup'"
fi
else
- errorEcho "Existing file '$targetPath' is in the way"
+ errorEcho "Existing file '$targetPath' is in the way of '$sourcePath'"
collision=1
fi
fi