aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
committerKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
commitc488527c95c874d3b8743c915173ad7bfb05d5af (patch)
tree2b874dc5606a9dff44096a5e8557f00dc52ac2b6 /home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
parent899a451e08f7d6d2c8214d119c2a0316849a0ed4 (diff)
parent6cc4fd6ede4909226cb81d3475834251ed1b7210 (diff)
Merge commit '6cc4fd6ede4909226cb81d3475834251ed1b7210'
Diffstat (limited to 'home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix')
-rw-r--r--home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix b/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
index b7eb3decebb..015efe6154a 100644
--- a/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
+++ b/home-manager/tests/modules/misc/xsession/keyboard-without-layout.nix
@@ -8,9 +8,7 @@ with lib;
home.homeDirectory = "/test-home";
- home.keyboard = {
- options = [ "ctrl:nocaps" "altwin:no_win" ];
- };
+ home.keyboard = { options = [ "ctrl:nocaps" "altwin:no_win" ]; };
xsession = {
enable = true;
@@ -20,14 +18,19 @@ with lib;
profileExtra = "profile extra commands";
};
+ nixpkgs.overlays = [
+ (self: super: {
+ xorg = super.xorg // {
+ setxkbmap = super.xorg.setxkbmap // { outPath = "@setxkbmap@"; };
+ };
+ })
+ ];
+
nmt.script = ''
assertFileExists home-files/.config/systemd/user/setxkbmap.service
assertFileContent \
home-files/.config/systemd/user/setxkbmap.service \
- ${pkgs.substituteAll {
- src = ./keyboard-without-layout-expected.service;
- inherit (pkgs.xorg) setxkbmap;
- }}
+ ${./keyboard-without-layout-expected.service}
'';
};
}