aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/services/gnome-keyring.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
committerKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
commitc488527c95c874d3b8743c915173ad7bfb05d5af (patch)
tree2b874dc5606a9dff44096a5e8557f00dc52ac2b6 /home-manager/modules/services/gnome-keyring.nix
parent899a451e08f7d6d2c8214d119c2a0316849a0ed4 (diff)
parent6cc4fd6ede4909226cb81d3475834251ed1b7210 (diff)
Merge commit '6cc4fd6ede4909226cb81d3475834251ed1b7210'
Diffstat (limited to 'home-manager/modules/services/gnome-keyring.nix')
-rw-r--r--home-manager/modules/services/gnome-keyring.nix27
1 files changed, 9 insertions, 18 deletions
diff --git a/home-manager/modules/services/gnome-keyring.nix b/home-manager/modules/services/gnome-keyring.nix
index 4ca6c7cacf2..6d8317dcffc 100644
--- a/home-manager/modules/services/gnome-keyring.nix
+++ b/home-manager/modules/services/gnome-keyring.nix
@@ -6,9 +6,7 @@ let
cfg = config.services.gnome-keyring;
-in
-
-{
+in {
meta.maintainers = [ maintainers.rycee ];
options = {
@@ -16,8 +14,8 @@ in
enable = mkEnableOption "GNOME Keyring";
components = mkOption {
- type = types.listOf (types.enum ["pkcs11" "secrets" "ssh"]);
- default = [];
+ type = types.listOf (types.enum [ "pkcs11" "secrets" "ssh" ]);
+ default = [ ];
description = ''
The GNOME keyring components to start. If empty then the
default set of components will be started.
@@ -34,22 +32,15 @@ in
};
Service = {
- ExecStart =
- let
- args = concatStringsSep " " (
- [ "--start" "--foreground" ]
- ++ optional (cfg.components != []) (
- "--components=" + concatStringsSep "," cfg.components
- )
- );
- in
- "${pkgs.gnome3.gnome_keyring}/bin/gnome-keyring-daemon ${args}";
+ ExecStart = let
+ args = concatStringsSep " " ([ "--start" "--foreground" ]
+ ++ optional (cfg.components != [ ])
+ ("--components=" + concatStringsSep "," cfg.components));
+ in "${pkgs.gnome3.gnome_keyring}/bin/gnome-keyring-daemon ${args}";
Restart = "on-abort";
};
- Install = {
- WantedBy = [ "graphical-session-pre.target" ];
- };
+ Install = { WantedBy = [ "graphical-session-pre.target" ]; };
};
};
}