aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/noti.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
committerKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
commitc488527c95c874d3b8743c915173ad7bfb05d5af (patch)
tree2b874dc5606a9dff44096a5e8557f00dc52ac2b6 /home-manager/modules/programs/noti.nix
parent899a451e08f7d6d2c8214d119c2a0316849a0ed4 (diff)
parent6cc4fd6ede4909226cb81d3475834251ed1b7210 (diff)
Merge commit '6cc4fd6ede4909226cb81d3475834251ed1b7210'
Diffstat (limited to 'home-manager/modules/programs/noti.nix')
-rw-r--r--home-manager/modules/programs/noti.nix13
1 files changed, 5 insertions, 8 deletions
diff --git a/home-manager/modules/programs/noti.nix b/home-manager/modules/programs/noti.nix
index 476c2eb1978..348555eef51 100644
--- a/home-manager/modules/programs/noti.nix
+++ b/home-manager/modules/programs/noti.nix
@@ -1,4 +1,4 @@
-{ config, lib, pkgs, ...}:
+{ config, lib, pkgs, ... }:
with lib;
@@ -6,9 +6,7 @@ let
cfg = config.programs.noti;
-in
-
-{
+in {
meta.maintainers = [ maintainers.marsam ];
options.programs.noti = {
@@ -16,7 +14,7 @@ in
settings = mkOption {
type = types.attrsOf (types.attrsOf types.str);
- default = {};
+ default = { };
description = ''
Configuration written to
<filename>~/.config/noti/noti.yaml</filename>.
@@ -45,9 +43,8 @@ in
config = mkIf cfg.enable {
home.packages = [ pkgs.noti ];
- xdg.configFile."noti/noti.yaml" = mkIf (cfg.settings != {}) {
- text = generators.toYAML {} cfg.settings;
- };
+ xdg.configFile."noti/noti.yaml" =
+ mkIf (cfg.settings != { }) { text = generators.toYAML { } cfg.settings; };
};
}