aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/msmtp.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2019-10-05 12:06:29 +0000
committerKatharina Fey <kookie@spacekookie.de>2019-10-05 12:42:50 +0000
commit1148b1d122bc03e9a3665856c9b7bb96bd4e3994 (patch)
tree1a9586de593790e236349d5caa0abdff7f3f6856 /home-manager/modules/programs/msmtp.nix
parent919d4e75699aa4ba456fd2d3d416a0522c9c7294 (diff)
parent8bddc1adab0f7a51476f819fa2197353e8e1d136 (diff)
Add 'home-manager/' from commit '8bddc1adab0f7a51476f819fa2197353e8e1d136'
git-subtree-dir: home-manager git-subtree-mainline: 919d4e75699aa4ba456fd2d3d416a0522c9c7294 git-subtree-split: 8bddc1adab0f7a51476f819fa2197353e8e1d136
Diffstat (limited to 'home-manager/modules/programs/msmtp.nix')
-rw-r--r--home-manager/modules/programs/msmtp.nix79
1 files changed, 79 insertions, 0 deletions
diff --git a/home-manager/modules/programs/msmtp.nix b/home-manager/modules/programs/msmtp.nix
new file mode 100644
index 00000000000..1ff3139ef36
--- /dev/null
+++ b/home-manager/modules/programs/msmtp.nix
@@ -0,0 +1,79 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+ cfg = config.programs.msmtp;
+
+ msmtpAccounts = filter (a: a.msmtp.enable)
+ (attrValues config.accounts.email.accounts);
+
+ onOff = p: if p then "on" else "off";
+
+ accountStr = account: with account;
+ concatStringsSep "\n" (
+ [ "account ${name}" ]
+ ++ mapAttrsToList (n: v: n + " " + v) (
+ {
+ host = smtp.host;
+ from = address;
+ auth = "on";
+ user = userName;
+ tls = onOff smtp.tls.enable;
+ tls_starttls = onOff smtp.tls.useStartTls;
+ tls_trust_file = smtp.tls.certificatesFile;
+ }
+ // optionalAttrs (msmtp.tls.fingerprint != null) {
+ tls_fingerprint = msmtp.tls.fingerprint;
+ }
+ // optionalAttrs (smtp.port != null) {
+ port = toString smtp.port;
+ }
+ // optionalAttrs (passwordCommand != null) {
+ # msmtp requires the password to finish with a newline.
+ passwordeval = ''${pkgs.bash}/bin/bash -c "${toString passwordCommand}; echo"'';
+ }
+ // msmtp.extraConfig
+ )
+ ++ optional primary "\naccount default : ${name}"
+ );
+
+ configFile = mailAccounts: ''
+ # Generated by Home Manager.
+
+ ${cfg.extraConfig}
+
+ ${concatStringsSep "\n\n" (map accountStr mailAccounts)}
+ '';
+
+in
+
+{
+
+ options = {
+ programs.msmtp = {
+ enable = mkEnableOption "msmtp";
+
+ extraConfig = mkOption {
+ type = types.lines;
+ default = "";
+ description = ''
+ Extra configuration lines to add to <filename>~/.msmtprc</filename>.
+ See <link xlink:href="https://marlam.de/msmtp/msmtprc.txt"/> for examples.
+ '';
+ };
+ };
+ };
+
+ config = mkIf cfg.enable {
+ home.packages = [ pkgs.msmtp ];
+
+ xdg.configFile."msmtp/config".text = configFile msmtpAccounts;
+
+ home.sessionVariables = {
+ MSMTP_QUEUE = "${config.xdg.dataHome}/msmtp/queue";
+ MSMTP_LOG = "${config.xdg.dataHome}/msmtp/queue.log";
+ };
+ };
+}