aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/matplotlib.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2019-10-05 12:06:29 +0000
committerKatharina Fey <kookie@spacekookie.de>2019-10-05 12:42:50 +0000
commit1148b1d122bc03e9a3665856c9b7bb96bd4e3994 (patch)
tree1a9586de593790e236349d5caa0abdff7f3f6856 /home-manager/modules/programs/matplotlib.nix
parent919d4e75699aa4ba456fd2d3d416a0522c9c7294 (diff)
parent8bddc1adab0f7a51476f819fa2197353e8e1d136 (diff)
Add 'home-manager/' from commit '8bddc1adab0f7a51476f819fa2197353e8e1d136'
git-subtree-dir: home-manager git-subtree-mainline: 919d4e75699aa4ba456fd2d3d416a0522c9c7294 git-subtree-split: 8bddc1adab0f7a51476f819fa2197353e8e1d136
Diffstat (limited to 'home-manager/modules/programs/matplotlib.nix')
-rw-r--r--home-manager/modules/programs/matplotlib.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/home-manager/modules/programs/matplotlib.nix b/home-manager/modules/programs/matplotlib.nix
new file mode 100644
index 00000000000..48ff6e60d68
--- /dev/null
+++ b/home-manager/modules/programs/matplotlib.nix
@@ -0,0 +1,64 @@
+{ config, lib, ... }:
+
+with lib;
+
+let
+
+ cfg = config.programs.matplotlib;
+
+ formatLine = o: n: v:
+ let
+ formatValue = v:
+ if isBool v then (if v then "True" else "False")
+ else toString v;
+ in
+ if isAttrs v
+ then concatStringsSep "\n" (mapAttrsToList (formatLine "${o}${n}.") v)
+ else (if v == "" then "" else "${o}${n}: ${formatValue v}");
+
+in
+
+{
+ meta.maintainers = [ maintainers.rprospero ];
+
+ options.programs.matplotlib = {
+ enable = mkEnableOption "matplotlib, a plotting library for python";
+
+ config = mkOption {
+ default = { };
+ type = types.attrs;
+ description = ''
+ Add terms to the <filename>matplotlibrc</filename> file to
+ control the default matplotlib behavior.
+ '';
+ example = literalExample ''
+ {
+ backend = "Qt5Agg";
+ axes = {
+ grid = true;
+ facecolor = "black";
+ edgecolor = "FF9900";
+ };
+ grid.color = "FF9900";
+ }
+ '';
+ };
+
+ extraConfig = mkOption {
+ type = types.lines;
+ default = "";
+ description = ''
+ Additional commands for matplotlib that will be added to the
+ <filename>matplotlibrc</filename> file.
+ '';
+ };
+ };
+
+ config = mkIf cfg.enable {
+ xdg.configFile."matplotlib/matplotlibrc".text =
+ concatStringsSep "\n" ([]
+ ++ mapAttrsToList (formatLine "") cfg.config
+ ++ optional (cfg.extraConfig != "") cfg.extraConfig
+ ) + "\n";
+ };
+}