aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/jq.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
committerKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
commitc488527c95c874d3b8743c915173ad7bfb05d5af (patch)
tree2b874dc5606a9dff44096a5e8557f00dc52ac2b6 /home-manager/modules/programs/jq.nix
parent899a451e08f7d6d2c8214d119c2a0316849a0ed4 (diff)
parent6cc4fd6ede4909226cb81d3475834251ed1b7210 (diff)
Merge commit '6cc4fd6ede4909226cb81d3475834251ed1b7210'
Diffstat (limited to 'home-manager/modules/programs/jq.nix')
-rw-r--r--home-manager/modules/programs/jq.nix26
1 files changed, 13 insertions, 13 deletions
diff --git a/home-manager/modules/programs/jq.nix b/home-manager/modules/programs/jq.nix
index 56c3adf0654..6c89df0df93 100644
--- a/home-manager/modules/programs/jq.nix
+++ b/home-manager/modules/programs/jq.nix
@@ -15,19 +15,17 @@ let
colorsType = types.submodule {
options = {
- null = colorType;
- false = colorType;
- true = colorType;
+ null = colorType;
+ false = colorType;
+ true = colorType;
numbers = colorType;
strings = colorType;
- arrays = colorType;
+ arrays = colorType;
objects = colorType;
};
};
-in
-
-{
+in {
options = {
programs.jq = {
enable = mkEnableOption "the jq command-line JSON processor";
@@ -52,12 +50,12 @@ in
'';
default = {
- null = "1;30";
- false = "0;39";
- true = "0;39";
+ null = "1;30";
+ false = "0;39";
+ true = "0;39";
numbers = "0;39";
strings = "0;32";
- arrays = "1;39";
+ arrays = "1;39";
objects = "1;39";
};
@@ -69,8 +67,10 @@ in
config = mkIf cfg.enable {
home.packages = [ pkgs.jq ];
- home.sessionVariables = let c = cfg.colors; in {
- JQ_COLORS = "${c.null}:${c.false}:${c.true}:${c.numbers}:${c.strings}:${c.arrays}:${c.objects}";
+ home.sessionVariables = let c = cfg.colors;
+ in {
+ JQ_COLORS =
+ "${c.null}:${c.false}:${c.true}:${c.numbers}:${c.strings}:${c.arrays}:${c.objects}";
};
};
}