aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/programs/alot-accounts.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
committerKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
commitc488527c95c874d3b8743c915173ad7bfb05d5af (patch)
tree2b874dc5606a9dff44096a5e8557f00dc52ac2b6 /home-manager/modules/programs/alot-accounts.nix
parent899a451e08f7d6d2c8214d119c2a0316849a0ed4 (diff)
parent6cc4fd6ede4909226cb81d3475834251ed1b7210 (diff)
Merge commit '6cc4fd6ede4909226cb81d3475834251ed1b7210'
Diffstat (limited to 'home-manager/modules/programs/alot-accounts.nix')
-rw-r--r--home-manager/modules/programs/alot-accounts.nix25
1 files changed, 11 insertions, 14 deletions
diff --git a/home-manager/modules/programs/alot-accounts.nix b/home-manager/modules/programs/alot-accounts.nix
index 8f3ffdfb31e..89ae28f9c8e 100644
--- a/home-manager/modules/programs/alot-accounts.nix
+++ b/home-manager/modules/programs/alot-accounts.nix
@@ -18,12 +18,10 @@ with lib;
type = types.attrsOf types.str;
default = {
type = "shellcommand";
- command = "'${pkgs.notmuch}/bin/notmuch address --format=json --output=recipients date:6M..'";
- regexp =
- "'\\[?{"
- + ''"name": "(?P<name>.*)", ''
- + ''"address": "(?P<email>.+)", ''
- + ''"name-addr": ".*"''
+ command =
+ "'${pkgs.notmuch}/bin/notmuch address --format=json --output=recipients date:6M..'";
+ regexp = "'\\[?{" + ''
+ "name": "(?P<name>.*)", "address": "(?P<email>.+)", "name-addr": ".*"''
+ "}[,\\]]?'";
shellcommand_external_filtering = "False";
};
@@ -36,9 +34,9 @@ with lib;
}
'';
description = ''
- Contact completion configuration as expected per alot.
- See <link xlink:href="http://alot.readthedocs.io/en/latest/configuration/contacts_completion.html">alot's wiki</link> for
- explanation about possible values.
+ Contact completion configuration as expected per alot.
+ See <link xlink:href="http://alot.readthedocs.io/en/latest/configuration/contacts_completion.html">alot's wiki</link> for
+ explanation about possible values.
'';
};
@@ -52,10 +50,9 @@ with lib;
};
config = mkIf config.notmuch.enable {
- alot.sendMailCommand = mkOptionDefault (
- if config.msmtp.enable
- then "msmtpq --read-envelope-from --read-recipients"
- else null
- );
+ alot.sendMailCommand = mkOptionDefault (if config.msmtp.enable then
+ "msmtpq --read-envelope-from --read-recipients"
+ else
+ null);
};
}