aboutsummaryrefslogtreecommitdiff
path: root/home-manager/modules/lib/shell.nix
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
committerKatharina Fey <kookie@spacekookie.de>2020-02-03 10:05:30 +0100
commitc488527c95c874d3b8743c915173ad7bfb05d5af (patch)
tree2b874dc5606a9dff44096a5e8557f00dc52ac2b6 /home-manager/modules/lib/shell.nix
parent899a451e08f7d6d2c8214d119c2a0316849a0ed4 (diff)
parent6cc4fd6ede4909226cb81d3475834251ed1b7210 (diff)
Merge commit '6cc4fd6ede4909226cb81d3475834251ed1b7210'
Diffstat (limited to 'home-manager/modules/lib/shell.nix')
-rw-r--r--home-manager/modules/lib/shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/home-manager/modules/lib/shell.nix b/home-manager/modules/lib/shell.nix
index f1443c5466a..5e5743f51ea 100644
--- a/home-manager/modules/lib/shell.nix
+++ b/home-manager/modules/lib/shell.nix
@@ -2,7 +2,7 @@
rec {
# Produces a Bourne shell like variable export statement.
- export = n: v: "export ${n}=\"${toString v}\"";
+ export = n: v: ''export ${n}="${toString v}"'';
# Given an attribute set containing shell variable names and their
# assignment, this function produces a string containing an export