aboutsummaryrefslogtreecommitdiff
path: root/home-manager/default.nix
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2017-05-21 23:54:38 +0200
committerRobert Helgesson <robert@rycee.net>2017-06-03 00:42:37 +0200
commit67391395ef5d2103327f35fc9182ff56754842c4 (patch)
tree84ac4902dbb3cdbbaf6704f9488eb8b2d68f2571 /home-manager/default.nix
parentff65781b843be3cfd3dfa24bbf0f4d9e533891c3 (diff)
home-manager: use `NIX_PATH` to locate modules
This removes the old argument based method that Home Manager used to find its modules by a `NIX_PATH` based method. Specifically, this adds a `home-manager` Nix path prefix that can be overridden much like with the `nixpkgs` path prefix.
Diffstat (limited to 'home-manager/default.nix')
-rw-r--r--home-manager/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/home-manager/default.nix b/home-manager/default.nix
index f2b9949549b..79f3e6d0955 100644
--- a/home-manager/default.nix
+++ b/home-manager/default.nix
@@ -3,10 +3,10 @@
let
homeManagerExpr = pkgs.writeText "home-manager.nix" ''
- { pkgs ? import <nixpkgs> {}, confPath, modulesPath }:
+ { pkgs ? import <nixpkgs> {}, confPath }:
let
- env = import modulesPath {
+ env = import <home-manager> {
configuration = import confPath;
pkgs = pkgs;
};