aboutsummaryrefslogtreecommitdiff
path: root/home-manager/tests/modules/programs/fish/no-functions.nix
{ config, lib, ... }:

with lib;

{
  config = {
    programs.fish = {
      enable = true;

      functions = { };
    };

    nmt = {
      description =
        "if fish.functions is blank, the functions folder should not exist.";
      script = ''
        assertPathNotExists home-files/.config/fish/functions
      '';

    };
  };
}