aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ab2f46..abe82d3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,10 +3,11 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c11")
set(CMAKE_BUILD_TYPE Debug)
project(bowl)
-add_library(bowl SHARED bowl.c
+add_library(bowl SHARED array.c
+ bowl.c
data.c
- utils.c
- array.c)
+ hash.c
+ utils.c)
target_include_directories(bowl PUBLIC ".")
@@ -15,4 +16,4 @@ add_executable(ex_tree examples/tree.c)
target_link_libraries(ex_tree bowl)
add_executable(ex_list examples/list.c)
-target_link_libraries(ex_list bowl) \ No newline at end of file
+target_link_libraries(ex_list bowl)