aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKatharina Fey <kookie@spacekookie.de>2016-07-30 21:26:43 +0200
committerKatharina Fey <kookie@spacekookie.de>2016-07-30 21:26:43 +0200
commit7d6b295c9e3f2ae3279039fb50f9e3bb0478074c (patch)
treee763e5698446c50b21adb9b43ddd95af39bd8657 /CMakeLists.txt
parent1337e4a7be1bc6db2bf820b1f5b55764c417b33a (diff)
Initial commit of the library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..6a90f6b
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,25 @@
+############################################
+#
+# libdyntree uses cmake because it's simple
+# Build instructions can be found in the README
+#
+############################################
+
+# Set some flags
+cmake_minimum_required(VERSION 2.8.11)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c11")
+set(CMAKE_BUILD_TYPE Debug)
+
+# Create our project for further reference
+project(libdyntree)
+set(DYN_TREE_SRC lib/dyn_tree.c)
+
+# Define our library in cmake
+add_library(libdyntree STATIC ${DYN_TREE_SRC})
+
+# Include the subdirectories to search for headers
+target_include_directories(libdyntree PUBLIC "include")
+target_include_directories(libdyntree PRIVATE "lib")
+
+# since the name starts with 'lib' dont add it again
+set_target_properties(libdyntree PROPERTIES PREFIX "")