aboutsummaryrefslogtreecommitdiff
path: root/modules/tint/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/tint/default.nix')
-rw-r--r--modules/tint/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/modules/tint/default.nix b/modules/tint/default.nix
new file mode 100644
index 000000000000..df0ed6851a2a
--- /dev/null
+++ b/modules/tint/default.nix
@@ -0,0 +1,20 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+ cfg = config.tint;
+in {
+ options.tint = {
+ enable = mkEnableOption "tint coreboot secondary payload";
+ };
+
+ config = lib.mkIf cfg.enable {
+ corenix.extraFiles = {
+ "img/tint" = {
+ type = "payload";
+ src = "${pkgs.coreboot-payload-tint}/tint.elf";
+ };
+ };
+ };
+}