aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/ui/i3/hm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/workstation/ui/i3/hm.nix')
-rw-r--r--infra/libkookie/modules/workstation/ui/i3/hm.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/infra/libkookie/modules/workstation/ui/i3/hm.nix b/infra/libkookie/modules/workstation/ui/i3/hm.nix
index 0341fc5b07ac..23aef4337a67 100644
--- a/infra/libkookie/modules/workstation/ui/i3/hm.nix
+++ b/infra/libkookie/modules/workstation/ui/i3/hm.nix
@@ -18,13 +18,25 @@ in
'';
};
+ # TODO: figure out a way to make this a package type
fonts = mkOption {
- type = with types; listOf package;
+ type = with types; listOf str;
default = [ "monospace" ];
description = ''
A set of fonts to use by the i3 module for rendering text
'';
};
+
+ i3Status = mkOption {
+ type = with types; submodule {
+ options = {
+ colors = mkOption { type = bool; default = true; };
+ format = mkOption { type = str; default = "dzen2"; };
+ interval = mkOption { type = int; default = 1; };
+ segments = mkOption { type = listOf str; default = []; };
+ };
+ };
+ };
};
config = (import core/setup.nix args);