aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/modules/workstation/emacs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/modules/workstation/emacs/default.nix')
-rw-r--r--infra/libkookie/modules/workstation/emacs/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/infra/libkookie/modules/workstation/emacs/default.nix b/infra/libkookie/modules/workstation/emacs/default.nix
new file mode 100644
index 000000000000..57949cb333b7
--- /dev/null
+++ b/infra/libkookie/modules/workstation/emacs/default.nix
@@ -0,0 +1,18 @@
+/**
+ * A custom wrapper module to configure an emacs installation.
+ *
+ */
+
+{ config, lib, pkgs, home-manager, options, ...} @ args:
+
+let cfg = config.libkookie.emacs;
+in
+with lib;
+{
+ options.libkookie.emacs = {
+ enable = mkEnableOption "emacs configuration module";
+ };
+
+ config = (lib.trace args.options {}); # (import ./core.nix args);
+}
+