aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/home-manager/tests/modules/xresources/xresources.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/home-manager/tests/modules/xresources/xresources.nix')
-rw-r--r--infra/libkookie/home-manager/tests/modules/xresources/xresources.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/infra/libkookie/home-manager/tests/modules/xresources/xresources.nix b/infra/libkookie/home-manager/tests/modules/xresources/xresources.nix
new file mode 100644
index 000000000000..f73e326f31e4
--- /dev/null
+++ b/infra/libkookie/home-manager/tests/modules/xresources/xresources.nix
@@ -0,0 +1,22 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ config = {
+ xresources = {
+ properties = {
+ "Test*string" = "test-string";
+ "Test*boolean1" = true;
+ "Test*boolean2" = false;
+ "Test*int" = 10;
+ "Test*list" = [ "list-str" true false 10 ];
+ };
+ };
+
+ nmt.script = ''
+ assertFileExists home-files/.Xresources
+ assertFileContent home-files/.Xresources ${./xresources-expected.conf}
+ '';
+ };
+}