aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix')
-rw-r--r--infra/libkookie/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/infra/libkookie/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix b/infra/libkookie/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
new file mode 100644
index 000000000000..f162a486b8be
--- /dev/null
+++ b/infra/libkookie/home-manager/tests/modules/programs/rofi/assert-on-both-theme-and-colors.nix
@@ -0,0 +1,32 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ config = {
+ programs.rofi = {
+ enable = true;
+ theme = "foo";
+ colors = {
+ window = {
+ background = "background";
+ border = "border";
+ separator = "separator";
+ };
+ rows = { };
+ };
+ };
+
+ home.file.result.text = builtins.toJSON
+ (map (a: a.message) (filter (a: !a.assertion) config.assertions));
+
+ nixpkgs.overlays =
+ [ (self: super: { rofi = pkgs.writeScriptBin "dummy-rofi" ""; }) ];
+
+ nmt.script = ''
+ assertFileContent \
+ home-files/result \
+ ${./assert-on-both-theme-and-colors-expected.json}
+ '';
+ };
+}