aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/home-manager/modules/targets/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/home-manager/modules/targets/darwin.nix')
-rw-r--r--infra/libkookie/home-manager/modules/targets/darwin.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/infra/libkookie/home-manager/modules/targets/darwin.nix b/infra/libkookie/home-manager/modules/targets/darwin.nix
new file mode 100644
index 000000000000..118321e8f117
--- /dev/null
+++ b/infra/libkookie/home-manager/modules/targets/darwin.nix
@@ -0,0 +1,16 @@
+{ config, lib, pkgs, ... }:
+
+{
+ # Disabled for now due to conflicting behavior with nix-darwin. See
+ # https://github.com/nix-community/home-manager/issues/1341#issuecomment-687286866
+ config = lib.mkIf (false && pkgs.stdenv.hostPlatform.isDarwin) {
+ # Install MacOS applications to the user environment.
+ home.file."Applications/Home Manager Apps".source = let
+ apps = pkgs.buildEnv {
+ name = "home-manager-applications";
+ paths = config.home.packages;
+ pathsToLink = "/Applications";
+ };
+ in "${apps}/Applications";
+ };
+}