aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/home-manager/modules/services/tahoe-lafs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/home-manager/modules/services/tahoe-lafs.nix')
-rw-r--r--infra/libkookie/home-manager/modules/services/tahoe-lafs.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/infra/libkookie/home-manager/modules/services/tahoe-lafs.nix b/infra/libkookie/home-manager/modules/services/tahoe-lafs.nix
new file mode 100644
index 000000000000..742b779b270f
--- /dev/null
+++ b/infra/libkookie/home-manager/modules/services/tahoe-lafs.nix
@@ -0,0 +1,19 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ meta.maintainers = [ maintainers.rycee ];
+
+ options = {
+ services.tahoe-lafs = { enable = mkEnableOption "Tahoe-LAFS"; };
+ };
+
+ config = mkIf config.services.tahoe-lafs.enable {
+ systemd.user.services.tahoe-lafs = {
+ Unit = { Description = "Tahoe-LAFS"; };
+
+ Service = { ExecStart = "${pkgs.tahoelafs}/bin/tahoe run -C %h/.tahoe"; };
+ };
+ };
+}