aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/home-manager/modules/programs/astroid-accounts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/home-manager/modules/programs/astroid-accounts.nix')
-rw-r--r--infra/libkookie/home-manager/modules/programs/astroid-accounts.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/infra/libkookie/home-manager/modules/programs/astroid-accounts.nix b/infra/libkookie/home-manager/modules/programs/astroid-accounts.nix
new file mode 100644
index 000000000000..fb803867efbe
--- /dev/null
+++ b/infra/libkookie/home-manager/modules/programs/astroid-accounts.nix
@@ -0,0 +1,32 @@
+{ config, lib, ... }:
+
+with lib;
+
+{
+ options.astroid = {
+ enable = mkEnableOption "Astroid";
+
+ sendMailCommand = mkOption {
+ type = types.str;
+ description = ''
+ Command to send a mail. If msmtp is enabled for the account,
+ then this is set to
+ <command>msmtpq --read-envelope-from --read-recipients</command>.
+ '';
+ };
+
+ extraConfig = mkOption {
+ type = types.attrsOf types.anything;
+ default = { };
+ example = { select_query = ""; };
+ description = ''
+ Extra settings to add to this astroid account configuration.
+ '';
+ };
+ };
+
+ config = mkIf config.notmuch.enable {
+ astroid.sendMailCommand = mkIf config.msmtp.enable
+ (mkOptionDefault "msmtpq --read-envelope-from --read-recipients");
+ };
+}