aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/home-manager/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/home-manager/flake.nix')
-rw-r--r--infra/libkookie/home-manager/flake.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/infra/libkookie/home-manager/flake.nix b/infra/libkookie/home-manager/flake.nix
new file mode 100644
index 000000000000..b0aa6095ac63
--- /dev/null
+++ b/infra/libkookie/home-manager/flake.nix
@@ -0,0 +1,24 @@
+{
+ description = "Home Manager for Nix";
+
+ outputs = { self, nixpkgs }: rec {
+ nixosModules.home-manager = import ./nixos;
+
+ darwinModules.home-manager = import ./nix-darwin;
+
+ lib = {
+ hm = import ./modules/lib { lib = nixpkgs.lib; };
+ homeManagerConfiguration = { configuration, system, homeDirectory
+ , username
+ , pkgs ? builtins.getAttr system nixpkgs.outputs.legacyPackages
+ , check ? true }@args:
+ import ./modules {
+ inherit pkgs check;
+ configuration = { ... }: {
+ imports = [ configuration ];
+ home = { inherit homeDirectory username; };
+ };
+ };
+ };
+ };
+}