aboutsummaryrefslogtreecommitdiff
path: root/infra/libkookie/configuration/workstation/devel/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'infra/libkookie/configuration/workstation/devel/default.nix')
-rw-r--r--infra/libkookie/configuration/workstation/devel/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/infra/libkookie/configuration/workstation/devel/default.nix b/infra/libkookie/configuration/workstation/devel/default.nix
new file mode 100644
index 000000000000..968387a9b84d
--- /dev/null
+++ b/infra/libkookie/configuration/workstation/devel/default.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+
+let
+ # Override git to include SVN and e-mail support. Also disable install checks
+ git = (pkgs.git.override { svnSupport = true; sendEmailSupport = true; })
+ .overrideAttrs ({ ...}: { doInstallCheck = false; });
+in
+{
+ home.packages = with pkgs; [
+
+ # Custom emacs with modules
+ libkookie-emacs
+
+ # Rust development
+ rustup
+
+ # Java/ Android development
+ android-studio
+
+ # Direnv is used to trigger lorri env
+ direnv
+ ];
+
+ services.lorri.enable = true;
+}