aboutsummaryrefslogtreecommitdiff
path: root/games/rstnode/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'games/rstnode/shell.nix')
-rw-r--r--games/rstnode/shell.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/rstnode/shell.nix b/games/rstnode/shell.nix
index 98465394e67e..207d5ef3cd33 100644
--- a/games/rstnode/shell.nix
+++ b/games/rstnode/shell.nix
@@ -1,7 +1,7 @@
with import <nixpkgs> {};
-stdenv.mkDerivation {
- name = "rstnode";
+mkShell rec {
+ name = "rstnode-shell";
buildInputs = with pkgs; [
rustc cargo clangStdenv rust-analyzer rustfmt
alsaLib pkg-config libudev
@@ -18,4 +18,6 @@ stdenv.mkDerivation {
libxcb
libxkbcommon
]);
+
+ LD_LIBRARY_PATH = (lib.makeLibraryPath buildInputs);
}