aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 11 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index b235fa9ef5c1..5cf96ba82f04 100644
--- a/flake.nix
+++ b/flake.nix
@@ -28,12 +28,8 @@
configFile
];
}).config.corenix.rom;
- in {
- lib = {
- inherit makeDevice;
- };
- packages.x86_64-linux = {
+ exportedPkgs = {
inherit (pkgs)
coreboot
coreboot-payload-grub2
@@ -45,5 +41,15 @@
milan-x1c = makeDevice ./configs/milan-x1c.nix;
milan-x230t = makeDevice ./configs/milan-x230t.nix;
};
+
+ in {
+ lib = {
+ inherit makeDevice;
+ };
+
+ packages.x86_64-linux = exportedPkgs;
+
+ # shortcut for use with flake-compat
+ pkgs = exportedPkgs;
};
}